题目描述
输入一个字符串,输出该字符串是否回文。回文是指顺读和倒读都一样的字符串。
输入格式
输入为一行字符串(字符串中没有空白字符,字符串长度不超过100)
输出格式
如果字符串是回文,输出yes;否则,输出no。
样例
样例输入
abcdedcba
样例输出
yes
========
#include<bits/stdc++.h>
#include<iostream>
#include<cctype>
using namespace std;
int main(){
string s;
cin>>s;
int flag=0;
for(int i=0,j=s.size()-1;i<j;i++,j--){
if(s[i]==s[j])
continue;
else
flag=1;
}
if(flag)
cout<<"no"<<endl;
else
cout<<"yes"<<endl;
return 0;
}
===
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int main() {
bool flag=true;
char str[100];
gets(str);
int len;
len=strlen(str);
for(int i=0; i<len; i++) {
if(str[i]!=str[len-1-i]) {//如果第i项等于倒数第i项
flag=false;
}
}
if(flag) {
cout << "yes";
} else {
cout << "no";
}
return 0;
}